Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Background removal not working in SLOBS

David May 16, 2018 10:41PM CDT

So, I've purchased a C922 as an upgrade from my old camera, and with hopes that Chromacam would work better with it as well.

However, it would seem that the straight up background removal doesn't work in Streamlabs OBS (SLOBS) when selecting Chromacam, and using the background as that funky camera thing in your logo. I can use one of the other backgrounds, but the removal doesn't work.

The background removal does work in the regular OBS though.

Suggestions? Anyone in contact with streamlabs to get sorted?

Up 1 rated Down
Support Team May 17, 2018 11:56AM CDT ChromaCam ChromaCamSupport

Hi David, does CC work on your setup with Google Hangouts or Zoom?

Up 0 rated Down
David May 21, 2018 09:14PM CDT
I've just tried on Google Hangouts and it's not working there either.
Up 0 rated Down
Malcolm May 22, 2018 02:21AM CDT
I am also using Streamlabs OBS (SLOBS) to stream with my hd webcam and the program is cutting me out more than the background itself. The more I move around or shift, it buffers the background too much that reveals it again and then erases me. But in regular OBS, it works fine with the background remove, in SLOBS its just blurring it out instead of clear.
Up 0 rated Down
Support Team May 23, 2018 04:45PM CDT ChromaCam ChromaCamSupport

With the raft of recent Windows Updates, some of the GPU drivers aren’t keeping pace as fast, which can affect graphics related output like camera feeds, etc. Updating them should solve this for you.

In the Windows Search bar type “device manager”. Then click on the “display adapter” drop down. Locate your GPU, right click on it and then “update driver software.”
Did that help at all?

What you need to also do is update any other GPU drivers as well. For me, in device manager > display adapter. I have my nVidia GPU there, but I also have a listing for Intel HD Graphics. Right-clicking and updating the drivers for this listing is necessary too.

Did that help?

Best
Nick

Up 0 rated Down
David May 26, 2018 08:38AM CDT
I'm trying to unistall it as, it appears that finally the Logitech camera tried to up date and install a version of Chromacam for c922. It said that I would need to select in OBS Chromacam (C922), however that doesn't appear in the selection window. So possibly I had an issue from already having installed Chromacam from the website.

All drivers are up to date by the way. Again, it will work on OBS but not on SLOBS
Up 0 rated Down
David May 26, 2018 08:40AM CDT
Well, even more interesting. Try to uninstall and it says to close the process. I'm not seeing any process related to Chromacam. What are the processes titled?
Up 0 rated Down
David Nelson May 30, 2018 07:47AM CDT
I did finally get it uninstalled. Is there a specific download for the C922?
Up 0 rated Down
Support Team Jun 04, 2018 12:27PM CDT ChromaCam ChromaCamSupport

The place to download the c922 no watermark version is on Logitech’s website.

Up 2 rated Down
Kurt Giese Jun 12, 2018 01:17PM CDT
This topic is still valid to me and one of my friends. SLOBS won't cut out the background for ChromaCam / Chromacam does not load when selected as video input.

All versions are up to date, all drivers are latest.

Please advise.
Up 0 rated Down
Mikey Crain Jul 03, 2018 04:40PM CDT
This is still not working correctly.
Up 0 rated Down
Support Team Jul 03, 2018 11:49PM CDT ChromaCam ChromaCamSupport

Are you using the 64-bit version of SLOBS? If yes, we are working on the 64-bit version of SLOBS currently and would advise you to use 32-bit version currently.

Up 0 rated Down
David Jul 10, 2018 03:02PM CDT
I'm also having trouble with setting the background to transparent or otherwise editing out the auto-chroma key green.
I'm using a C922 webcam, and have tried uninstalling and reinstalling Chromacam
Chromacam worked as advertised when I first set it up, but now I can't find any way to remove the background. Instead I'm stuck with the green screen, which people find more distracting that the background of where I am.
This problem occurs in Google Hangouts, Streamlabs OBS, and I can't get Skype to recognize Chromacam at all.
Up 0 rated Down
Support Team Jul 10, 2018 07:37PM CDT ChromaCam ChromaCamSupport

Hi there, does try an uninstall and re-install process helped you? The process looks like the below steps:

1. delete the folder “%localappdata%\Personify” In order to find the folder, type “%localappdata%” into the Windows Search bar on your desktop (without the quotes), and then navigate to the Personify folders once you click into the localappdata folder.
2. delete the folder “%localappdata%\Personify,_Inc”
3. download the latest version of chromacam from our website here: chromacam.me/download
4. run the installer, and then restart your PC.

Try these steps in that order, let me know if you have any questions. We’ll go from there if you’re still having issues.

Best,
Chromacam Support

Up 0 rated Down
louie perez Sep 01, 2018 06:50PM CDT
Hi ChromaCamSupport,

Ssame issue as above background removal not working it just blurs the background plain and simple.. All my softwarre is up to date windows, gpu, logitech, software.
Kindly address the isssue asap chromacam support.

Regards,
Up 0 rated Down
Harrison Sep 01, 2018 08:46PM CDT
Hello Support,

Yes, I'm also having the same issue. Using SLOBS, the software does not remove the background, it just blurs it slightly. Is there a way to force the software to actually remove the background for the video stream or something? What do you suggest we do?

Thanks!
Up 0 rated Down
Support Team Sep 11, 2018 12:44AM CDT ChromaCam ChromaCamSupport

Can you tell us what version are you using? 32-bit version or 64-bit version?

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
support@personifyinc.com
http://assets0.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete?b_id=15956