Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Chromacam not showing in any App using Logitech C922

RobF Jan 15, 2018 12:47AM CST

Brand new installation of Logitech C922 out of the box and Chromacam is not showing as a camera in any App at all. I only purchased this camera as it specifically promoted Chromacam as a "Feature"

I have read the forum and tried the following:
- Updated Display Adapter Drivers
- Clean Install of Chromacam including deleting folders and Appdata
- Rebooted several times between installs.
- Installed native Logitech camera software

Hardware Specs:
- Windows 10 (64-bit)
- Intel i7-7700 (supports AVX2 Instruction set)
- NVIDIA GeForce GTX 1060 6GB
- Logitech C922

Please help

Up 0 rated Down
Jarod997 Jan 22, 2018 10:30AM CST
What app are you trying to get it to work with? I can help with OBS.
Up 0 rated Down
Rob Jan 29, 2018 03:28AM CST
Jarod997

I have tried the following:
- Skype
- Zoom

I have no requirement for OBS
Up 0 rated Down
Ian Mar 23, 2018 07:36PM CDT
I have looked into every app and no change. i am trying to use for OBS but its not showing as an option i have also attempted everything listed above

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
support@personifyinc.com
http://assets1.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete?b_id=15956